Skip to main content
VulnerabilityPublished

CVE-2026-41686: anthropics anthropic-sdk-typescript · Incorrect Permissions

Affects anthropics anthropic-sdk-typescriptSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 0.91.1 when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.91.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade anthropic-sdk-typescript and anthropics/anthropic-sdk-typescript to 0.91.1.

Affected software

ProductAffectedFixed in
anthropicsanthropic-sdk-typescriptAffected
  • >=0.79.0 <0.91.1
Fixed in
  • 0.91.1
npmanthropics/anthropic-sdk-typescriptpkg:npm/anthropics/anthropic-sdk-typescriptOther threatsAffected
  • >=0.79.0 <0.91.1
Fixed in
  • 0.91.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the anthropic-sdk-typescript package to version 0.91.1 or later, where the issue has been patched. Since the vulnerability is fixed in this version, no additional mitigation steps are required.

Description

The Claude SDK for TypeScript versions from 0.79.0 up to but not including 0.91.1 had a vulnerability where memory files and directories were created with overly permissive default permissions. This allowed local attackers on shared hosts to read sensitive persisted agent state and, in containerized environments with permissive umasks, to modify these files potentially influencing model behavior. The issue was addressed in version 0.91.1.

References

Community reviews

Loading reviews…