CVE-2026-41715: Spring Reactor Netty · Insufficiently Protected Credentials
Affects Spring Reactor NettySource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 1.3.15.1 : update Spring Reactor Netty when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.15.1, 1.2.17.1, 1.1.36 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring Reactor Netty to 1.3.15.1, 1.2.17.1, 1.1.36 or 1.0.52.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringReactor Netty | Affected
| Fixed in
|
| SpringReactor Netty | Affected
| Fixed in
|
| SpringReactor Netty | Affected
| Fixed in
|
| SpringReactor Netty | Affected
| Fixed in
|
Mavenio.projectreactor/reactor-nettypkg:maven/io.projectreactor/reactor-nettyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid configuring the Reactor Netty HTTP client to follow redirects from secure to insecure endpoints. Review application configurations to prevent automatic redirect following in these scenarios.
Description
CVE-2026-41715 is a medium severity vulnerability in Spring Reactor Netty HTTP client where credentials may be leaked during HTTP redirects from secure to insecure endpoints if the client is configured to follow redirects. This affects versions 1.0.0 through 1.0.51, 1.1.0 through 1.1.35, 1.2.0 through 1.2.17, and 1.3.0 through 1.3.5.