CVE-2026-41732: Spring for Apache Pulsar · Deserialization of Untrusted Data
Affects Spring for Apache PulsarSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 2.0.5.1 : patch Spring for Apache Pulsar soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.5.1, 1.2.17.1, 1.1.18
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Spring for Apache Pulsar to 2.0.5.1, 1.2.17.1 or 1.1.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring for Apache Pulsar | Affected
| Fixed in
|
| SpringSpring for Apache Pulsar | Affected
| Fixed in
|
| SpringSpring for Apache Pulsar | Affected
| Fixed in
|
Mavenorg.springframework/spring-for-apache-pulsarpkg:maven/org.springframework/spring-for-apache-pulsarOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid using empty trusted-packages configurations and carefully restrict trusted packages to minimize exposure.
Description
JsonPulsarHeaderMapper matched type headers against trusted packages using a prefix check, meaning that trusting any package implicitly trusted all of its subpackages. Additionally, an empty trusted-packages configuration fell back to trusting all packages rather than applying a safe default allow-list. Affected versions: Spring for Apache Pulsar 2.0.0 through 2.0.5; 1.2.0 through 1.2.17; 1.1.0 through 1.1.17.