Skip to main content
VulnerabilityPublished

CVE-2026-4176: SHAY perl · Dependency on Vulnerable Third-Party Component

Affects SHAY perlSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.8 Critical · fixed in 5.43.9 : patch SHAY perl as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.43.9, 5.42.2-RC1, 5.40.4-RC1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade SHAY perl to 5.43.9, 5.42.2-RC1 or 5.40.4-RC1.

Affected software

ProductAffectedFixed in
SHAYperlAffected
  • >=5.43.0 <5.43.9
Fixed in
  • 5.43.9
SHAYperlAffected
  • >=5.41.0 <5.42.2-RC1
Fixed in
  • 5.42.2-RC1
SHAYperlAffected
  • >=5.9.4 <5.40.4-RC1
Fixed in
  • 5.40.4-RC1
GitHubperlpkg:github/perlOther threatsAffected
  • >=5.9.4 <5.40.4-RC1
  • >=5.41.0 <5.42.2-RC1
  • >=5.43.0 <5.43.9
Fixed in
  • 5.40.4-RC1
  • 5.42.2-RC1
  • 5.43.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in the Perl blead branch where Compress::Raw::Zlib was updated to version 2.221. Users should upgrade to Perl versions that include this updated module or apply the updated Compress::Raw::Zlib module to mitigate the vulnerability. Since this is not a cloud service, remediation depends on applying these updates in the affected environments. Patch status is confirmed by the Perl project's update to the module in blead. No vendor advisory content was provided beyond this update, so users should monitor official Perl release notes for stable releases containing this fix.

Description

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, and from 5.43.

References

Community reviews

Loading reviews…