Skip to main content
VulnerabilityPublished Updated

CVE-2026-41845: Spring Framework · Cross-site Scripting

Affects Spring FrameworkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 7.0.7.1 : patch Spring Framework soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.7.1, 6.2.18.1, 6.1.28 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Spring Framework to 7.0.7.1, 6.2.18.1, 6.1.28 or 5.3.49.

Affected software

ProductAffectedFixed in
SpringSpring FrameworkAffected
  • >=7.0.0 <7.0.7.1
Fixed in
  • 7.0.7.1
SpringSpring FrameworkAffected
  • >=6.2.0 <6.2.18.1
Fixed in
  • 6.2.18.1
SpringSpring FrameworkAffected
  • >=6.1.0 <6.1.28
Fixed in
  • 6.1.28
SpringSpring FrameworkAffected
  • >=5.3.0 <5.3.49
Fixed in
  • 5.3.49

AI-suggested

If you cannot patch yet, users should consider applying workarounds or additional input validation and output encoding controls where possible to mitigate the risk of JavaScript injection via the affected method.

Description

A cross-site scripting (XSS) vulnerability exists in the Spring Framework due to improper escaping in the JavaScriptUtils.javaScriptEscape() method. This flaw affects multiple versions of the Spring Framework, including 5.3.0 through 5.3.48, 6.1.0 through 6.1.27, 6.2.0 through 6.2.18, and 7.0.0 through 7.0.7. The vulnerability could allow an attacker to inject JavaScript code into the browser, potentially leading to information disclosure. The CVSS score is 7.1, indicating a high severity level.

References

Community reviews

Loading reviews…