CVE-2026-41850: Spring Framework · Inefficient Algorithmic Complexity
Affects Spring FrameworkSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 7.0.7.1 : patch Spring Framework soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.7.1, 6.2.18.1, 6.1.28 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Spring Framework to 7.0.7.1, 6.2.18.1, 6.1.28 or 5.3.49.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring Framework | Affected
| Fixed in
|
| SpringSpring Framework | Affected
| Fixed in
|
| SpringSpring Framework | Affected
| Fixed in
|
| SpringSpring Framework | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, it is recommended to avoid evaluating untrusted or user-supplied SpEL expressions or to implement strict input validation and resource usage limits on expression evaluation to mitigate potential denial of service.
Description
Spring Framework versions 5.3.0 through 5.3.48, 6.1.0 through 6.1.27, 6.2.0 through 6.2.18, and 7.0.0 through 7.0.7 are affected by an inefficient algorithmic complexity vulnerability in the evaluation of Spring Expression Language (SpEL) expressions. This vulnerability allows an attacker to supply specially crafted expressions that cause excessive resource consumption, potentially leading to denial of service conditions. The vulnerability is identified as CWE-407 and has a CVSS v3.1 score of 7.5, indicating high severity.