Skip to main content
VulnerabilityPublished

CVE-2026-41860: Cloud Foundry Foundation BOSH · Inadequate Encryption Strength

Affects Cloud Foundry Foundation BOSHSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 282.1.9 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.07% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 282.1.9
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Cloud Foundry Foundation BOSH to 282.1.9.

Affected software

ProductAffectedFixed in
Cloud Foundry FoundationBOSHAffected
  • <282.1.9
Fixed in
  • 282.1.9

AI-suggested

A fix is available in BOSH version 282.1.9 and later. Users should upgrade to version 282.1.9 or newer to remediate this vulnerability. No vendor advisory content is provided to indicate alternative mitigations or temporary fixes. Patch status beyond this upgrade is not explicitly confirmed; users should verify with official vendor advisories for the latest remediation guidance.

Description

CWE-326 in BOSH allows a local attacker to steal Basic-auth credentials or redirect UAA token requests via MITM. HttpRequestHelper#create_async_endpoint and #send_http_get_request_synchronous hard-code OpenSSL::SSL::VERIFY_NONE, enabling an attacker to intercept traffic between bosh-monitor and the BOSH director or UAA and steal credentials. Affected versions: - BOSH: all versions prior to v282.1.9 (inclusive); fixed in v282.1.9 or later

References

Community reviews

Loading reviews…