CVE-2026-42073: Gitlawb openclaude · Cross-Site Request Forgery (CSRF)
Affects Gitlawb openclaudeSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.5.1 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaude and gitlawb/openclaude to 0.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gitlawbopenclaude | Affected
| Fixed in
|
GitHubgitlawb/openclaudepkg:github/gitlawb/openclaudeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenClaude to version 0.5.1 or later, where this vulnerability has been patched. Since this is a client-side CLI tool and not a cloud service, users must apply the update themselves. Patch status is confirmed by the vendor stating the fix is included in version 0.5.1. No additional mitigations are indicated.
Description
OpenClaude is an open-source coding-agent command line interface for cloud and local model providers. Prior to version 0.5.1, the OpenClaude MCP authentication flow starts a temporary local HTTP server to handle OAuth callbacks. To prevent CSRF attacks, the server validates a state parameter against an internally stored value. However, due to a logic flaw in the order of conditionals, an attacker can completely bypass this check and force the server to shut down — without knowing the state value at all. This issue has been patched in version 0.5.1.