CVE-2026-42075: EvoMap evolver · Path Traversal
Affects EvoMap evolverSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.69.3 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.69.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade evolver and evomap/evolver to 1.69.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EvoMapevolver | Affected
| Fixed in
|
GitHubevomap/evolverpkg:github/evomap/evolverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade EvoMap evolver to version 1.69.3 or later, where this path traversal vulnerability has been patched. No other mitigation steps are indicated by the vendor advisory. Patch status is not explicitly confirmed by a vendor advisory link, but the description states the issue is fixed in version 1.69.3.
Description
Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a path traversal vulnerability in the skill download (fetch) command allows attackers to write files to arbitrary locations on the filesystem. The --out= flag accepts user-provided paths without validation, enabling directory traversal attacks that can overwrite critical system files or create files in sensitive location. This issue has been patched in version 1.69.3.