CVE-2026-42077: EvoMap evolver · Prototype Pollution
Affects EvoMap evolverSource CVE Database V5
Not known to be exploited · CVSS 5.2 Medium : upgrade to 1.69.3 when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.69.3
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade evolver and evomap/evolver to 1.69.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EvoMapevolver | Affected
| Fixed in
|
GitHubevomap/evolverpkg:github/evomap/evolverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in EvoMap evolver version 1.69.3. Users should upgrade to version 1.69.3 or later to remediate this issue. Since the product is not a cloud service, remediation depends on applying the vendor's patch. Patch status is not explicitly stated in the vendor advisory, but the description confirms the fix is included in version 1.69.3.
Description
Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a prototype pollution vulnerability in the mailbox store module allows attackers to modify the behavior of all JavaScript objects by injecting malicious properties into Object.prototype. The vulnerability exists in the _applyUpdate() and _updateRecord() functions which use Object.assign() to merge user-controlled data without filtering dangerous keys like __proto__, constructor, or prototype. This issue has been patched in version 1.69.3.