Skip to main content
VulnerabilityPublished

CVE-2026-42086: OpenC3 cosmos · Cross-site Scripting

Affects OpenC3 cosmosSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 7.0.0 when convenient.

Data as of 1 Nov 2026, 11:02 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade cosmos and openc3/cosmos to 7.0.0.

Affected software

ProductAffectedFixed in
OpenC3cosmosAffected
  • <7.0.0
Fixed in
  • 7.0.0
GitHubopenc3/cosmospkg:github/openc3/cosmosOther threatsAffected
  • <7.0.0
Fixed in
  • 7.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenC3 COSMOS to version 7.0.0 or later, where this vulnerability is patched. Since the issue is fixed in this version, no additional mitigation steps are required. Users should avoid using vulnerable versions and be cautious of phishing attempts that might trick them into executing malicious payloads.

Description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. Prior to version 7.0.0, the Command Sender UI uses an unsafe eval() function on array-like command parameters, which allows a user-supplied payload to execute in the browser when sending a command. This creates a self-XSS risk because an attacker can trigger their own script execution in the victim’s session, if allowed to influence the array parameter input, for example via phishing. If successful, an attacker may read or modify data in the authenticated browser context, including session tokens in local storage. This issue has been patched in version 7.0.0.

References

Community reviews

Loading reviews…