CVE-2026-42150: WeblateOrg wlc · Cross-site Scripting
Affects WeblateOrg wlcSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.0.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade wlc and weblateorg/wlc to 2.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WeblateOrgwlc | Affected
| Fixed in
|
GitHubweblateorg/wlcpkg:github/weblateorg/wlcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade wlc to version 2.0.0 or later, where the vulnerability has been patched. Since the vendor advisory confirms the fix in version 2.0.0, applying this update fully mitigates the issue. No additional mitigations are specifically recommended beyond upgrading.
Description
CVE-2026-42150 is a cross-site scripting (XSS) vulnerability in the Weblate command-line client (wlc) prior to version 2.0.0. The vulnerability arises because the HTML output format embeds API response data into HTML without proper escaping, which can lead to XSS when the output is viewed in a browser. This issue has been addressed in version 2.0.0 of wlc. The vulnerability has a medium severity with a CVSS score of 5.1.
References
- github.com/WeblateOrg/wlc/security/advisories/GHSA-gx2m-mcc2-r4p3 (opens in a new tab)
- github.com/WeblateOrg/wlc/pull/1327 (opens in a new tab)
- github.com/WeblateOrg/wlc/commit/0f3e58f6d7457b05d48ef40f579a172c4c8b8469 (opens in a new tab)
- github.com/WeblateOrg/wlc/releases/tag/2.0.0 (opens in a new tab)