Skip to main content
VulnerabilityPublished

CVE-2026-42227: n8n · Insecure Direct Object Reference

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium · fixed in 2.18.1 : update n8n when convenient.

Data as of 1 Nov 2026, 11:02 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.1, 2.17.4, 1.123.32
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.18.1, 2.17.4 or 1.123.32.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.18.0 <2.18.1
Fixed in
  • 2.18.1
n8n-ion8nAffected
  • >=2.17.0 <2.17.4
Fixed in
  • 2.17.4
n8n-ion8nAffected
  • <1.123.32
Fixed in
  • 1.123.32
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threatsAffected
  • <1.123.32
  • <2.17.4
  • <2.18.1
Fixed in
  • 1.123.32
  • 2.17.4
  • 2.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to these or later versions to remediate the issue. Additionally, if sensitive information was stored in variables, it is recommended to rotate those credentials or tokens immediately. No vendor advisory indicates alternative mitigations or that no action is required.

Description

CVE-2026-42227 is an authorization bypass vulnerability in the n8n workflow automation platform affecting certain enterprise and team deployments with multiple projects and the variables feature enabled. Authenticated users with a valid API key scoped to variable:list could read variables from projects they do not belong to by manipulating the projectId query parameter. This occurs because the API endpoint queried the variables repository directly without enforcing project membership checks. The vulnerability was patched in versions 1.123.32, 2.17.4, and 2.18.1.

References

Community reviews

Loading reviews…