Skip to main content
VulnerabilityPublished

CVE-2026-42234: n8n · Code Injection

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 2.18.1 : patch n8n soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.1, 2.17.4, 1.123.32
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.18.1, 2.17.4 or 1.123.32.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.18.0 <2.18.1
Fixed in
  • 2.18.1
n8n-ion8nAffected
  • >=2.17.0 <2.17.4
Fixed in
  • 2.17.4
n8n-ion8nAffected
  • <1.123.32
Fixed in
  • 1.123.32
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threatsAffected
  • <1.123.32
  • <2.17.4
  • <2.18.1
Fixed in
  • 1.123.32
  • 2.17.4
  • 2.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to one of these versions or later to remediate the issue. Since this is not a cloud service, patching the affected software instances is necessary. No alternative mitigations or temporary fixes are indicated in the available data.

Description

CVE-2026-42234 is a high-severity vulnerability in the n8n open source workflow automation platform. It affects versions prior to 1.123.32, 2.17.4, and 2.18.1 when the Python Task Runner is enabled. An authenticated user with permission to create or modify workflows containing a Python Code Node could escape the sandbox and execute arbitrary code on the task runner container. This vulnerability has been patched in the specified versions.

References

Community reviews

Loading reviews…