CVE-2026-42328: go-ipld-prime · Uncontrolled Recursion
Affects go-ipld-primeSource CVE Database V5
Not known to be exploited · CVSS 6.2 Medium : upgrade to 0.23.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.23.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade go-ipld-prime and github.com/ipld/go-ipld-prime to 0.23.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ipldgo-ipld-prime | Affected
| Fixed in
|
Gogithub.com/ipld/go-ipld-primepkg:golang/github.com/ipld/go-ipld-primeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to go-ipld-prime version 0.23.0 or later, where this uncontrolled recursion issue is fixed. Patch status is confirmed by the version information in the advisory. No additional mitigations are indicated.
Description
The go-ipld-prime library versions prior to 0.23.0 contain a vulnerability where the DAG-CBOR and DAG-JSON decoders perform uncontrolled recursion on deeply nested collections without a depth limit. This causes the Go runtime to terminate the process due to a fatal stack overflow. The issue is fixed in version 0.23.0.