CVE-2026-42358: Apache Airflow · Information Exposure
Affects Apache AirflowSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.2.2 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache Airflow and apache-airflow to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
PyPIapache-airflowpkg:pypi/apache-airflowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Airflow to version 3.2.2 or later to address this vulnerability. This update raises the recursion depth limit for the Variable response masker, ensuring sensitive keys in deeply nested JSON values are properly redacted. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-42358 is a vulnerability in Apache Airflow where the Variable response masker fails to redact sensitive nested keys in deeply nested JSON values beyond a certain recursion depth. Authenticated users with Variable read permission can access plaintext secrets stored under deeply nested keys named with sensitive suffixes like 'password' or 'token'. This issue affects versions prior to 3.2.2 and is a residual gap from a previous fix that only addressed shallower nesting. Upgrading to Apache Airflow 3.2.2 or later mitigates this vulnerability.