Skip to main content
VulnerabilityPublished Updated

CVE-2026-42359: Apache Airflow · Deserialization of Untrusted Data

Affects Apache AirflowSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.8 High : upgrade to 3.2.2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.2.0 <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • =3.2.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Airflow to version 3.2.2 or later to address this vulnerability. The vendor advisory indicates that the PATCH endpoint lacked the forbidden key validation present in the POST endpoint, which was fixed in 3.2.2. There is no indication that temporary mitigations or workarounds exist. Patch status is not explicitly stated but the advisory strongly recommends upgrading to 3.2.2 or later for full remediation.

Description

CVE-2026-42359 is a high-severity vulnerability in Apache Airflow 3.2.0 affecting the XCom PATCH endpoint. It allows an authenticated user with XCom write permission to set entries under reserved keys, bypassing existing validation. This can lead to remote code execution (RCE) when the affected task defers to the triggerer. The issue is a bypass of a previous fix (CVE-2026-33858) because the PATCH endpoint lacked the forbidden key validation present in the POST endpoint. Users who upgraded for the previous CVE must upgrade to Apache Airflow 3.2.2 or later to fully mitigate this vulnerability.

References

Community reviews

Loading reviews…