Skip to main content
VulnerabilityPublished

CVE-2026-42402: Apache Neethi · Uncontrolled Resource Consumption

Affects Apache NeethiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache NeethiAffected
  • <3.2.2
Fixed in
  • 3.2.2
MavenApache Software Foundation/org.apache.neethi:neethipkg:maven/Apache Software Foundation/org.apache.neethi:neethiOther threatsAffected
  • <3.2.2
Fixed in
  • 3.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache Neethi version 3.2.2 or later, which includes a fix that limits the maximum number of normalized policy alternatives during the normalization process. Patch status is not explicitly confirmed in the advisory fields, but the vendor recommends upgrading to 3.2.2 as the remediation. No other mitigations are specified.

Description

Apache Neethi is vulnerable to a Denial of Service attack through algorithmic complexity in policy normalization. Specially crafted WS-Policy documents can trigger an exponential Cartesian cross-product expansion during the normalization process, causing unbounded memory allocation that exhausts the JVM heap. This occurs when the normalization process generates an excessive number of policy alternatives without bounds, leading to runtime memory exhaustion. Users should upgrade to 3.2.2 which limits the maximum number of normalized policy alternatives.

References

Community reviews

Loading reviews…