CVE-2026-42457: loft · Cross-site Scripting
Affects loftSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical · fixed in 4.7.1 : patch loft as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.7.1, 4.6.2, 4.5.5 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade loft to 4.7.1, 4.6.2, 4.5.5 or 4.4.3; loft-sh/loft to 4.4.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| loft-shloft | Affected
| Fixed in
|
| loft-shloft | Affected
| Fixed in
|
| loft-shloft | Affected
| Fixed in
|
| loft-shloft | Affected
| Fixed in
|
GitHubloft-sh/loftpkg:github/loft-sh/loftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected loft-sh vCluster Platform installations to version 4.4.3, 4.5.5, 4.6.2, 4.7.1, or 4.8.0 or later, as these versions contain fixes for this vulnerability. Since no official vendor advisory or patch links are provided, verify the upgrade path and patch details with the vendor's official release notes or security advisories. Restrict namespace creation privileges to trusted users to reduce risk until the update is applied.
Description
A critical stored cross-site scripting (XSS) vulnerability exists in loft-sh's vCluster Platform prior to versions 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.