CVE-2026-42523: Jenkins GitHub Plugin · Cross-site Scripting
Affects Jenkins GitHub PluginSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical · fixed in 1.46.0.1 : patch Jenkins GitHub Plugin as a priority.
Data as of 30 Oct 2026, 06:59 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.46.0.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Jenkins ProjectJenkins GitHub Plugin | Affected
| Fixed in– |
AI-suggested
Upgrade the Jenkins GitHub Plugin to version 1.46.0.1 or later, where the vulnerability is fixed by removing the processing of the current job URL in the JavaScript validation. No other mitigation or workaround is indicated in the available data.
Description
A stored cross-site scripting (XSS) vulnerability exists in Jenkins GitHub Plugin versions 1.46.0 and earlier. The vulnerability arises from improper processing of the current job URL in JavaScript validation for the "GitHub hook trigger for GITScm polling" feature. This flaw allows non-anonymous users with Overall/Read permission to exploit the vulnerability. The issue is resolved starting from version 1.46.0.1, which no longer processes the current job URL in the vulnerable JavaScript code.