Skip to main content
VulnerabilityPublished

CVE-2026-42538: dfir-iris iris-web · Unrestricted File Upload

Affects dfir-iris iris-webSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.4.28 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.28
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade iris-web and dfir-iris/iris-web to 2.4.28.

Affected software

ProductAffectedFixed in
dfir-irisiris-webAffected
  • <2.4.28
Fixed in
  • 2.4.28
GitHubdfir-iris/iris-webpkg:github/dfir-iris/iris-webOther threatsAffected
  • <2.4.28
Fixed in
  • 2.4.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade dfir-iris iris-web to version 2.4.28 or later, which contains the patch for this vulnerability. No other mitigation guidance is provided or necessary as the issue is resolved in the fixed version.

Description

A vulnerability in dfir-iris iris-web prior to version 2.4.28 allows unrestricted upload of files with dangerous types due to improper validation. This can be exploited to host phishing pages and also leads to a Cross-Site Scripting (XSS) vulnerability. The issue is addressed in version 2.4.28.

References

Community reviews

Loading reviews…