Skip to main content
VulnerabilityPublished Updated

CVE-2026-42541: kubewarden-controller · Missing Authorization

Affects kubewarden-controllerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 1.35.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.35.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade kubewarden-controller and kubewarden/adm-controller to 1.35.0.

Affected software

ProductAffectedFixed in
kubewardenkubewarden-controllerAffected
  • <1.35.0
Fixed in
  • 1.35.0
GitHubkubewarden/adm-controllerpkg:github/kubewarden/adm-controllerOther threatsAffected
  • <1.35.0
Fixed in
  • 1.35.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in kubewarden-controller version 1.35.0. Users should upgrade to version 1.35.0 or later to remediate this issue. No vendor advisory content was provided to indicate alternative mitigations or that no action is required. Therefore, upgrading is the recommended remediation.

Description

Kubewarden is a policy engine for Kubernetes. Prior to , An attacker with privileged AdmissionPolicy or AdmissionPolicyGroup create permissions (which isn't the default) can craft a policy that makes use of the can_i host callback. The callback issues a SubjectAccessReview (SAR) requests to enumerate RBAC permissions of any user or service account across the cluster.can_i does not perform that check to enforce the context-aware allow-list and forwards the request directly to the callback handler, which executes a real SubjectAccessReview using policy-server privileges. This creates a policy-level authorization gap: can_i is effectively usable even when the policy has no context-aware resource grant. This is an information disclosure / reconnaissance issue, and not direct workload data exfiltration. The attacker learns permission information, such as whether specific service accounts can "get secrets", "create pods", or "bind clusterroles" in chosen namespaces. This vulnerability is fixed in .

References

Community reviews

Loading reviews…