CVE-2026-42548: flightphp core · Cross-site Scripting
Affects flightphp coreSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 3.18.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.18.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade core and flightphp/core to 3.18.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| flightphpcore | Affected
| Fixed in
|
GitHubflightphp/corepkg:github/flightphp/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in FlightPHP version 3.18.1. Users and administrators should upgrade to version 3.18.1 or later to remediate this issue. Since this is not a cloud service, patching the affected software is required to mitigate the risk. No vendor advisory content contradicts this; therefore, upgrading is the recommended action.
Description
FlightPHP core versions prior to 3.18.1 contain a reflected cross-site scripting (XSS) vulnerability in the Flight::jsonp() function. This occurs because the ? jsonp= query parameter is concatenated directly into a JavaScript response without validating that it is a legal JavaScript identifier. An attacker can exploit this to inject arbitrary JavaScript code that executes in the context of the response origin. The vulnerability is assigned CVE-2026-42548 and has a high severity score of 8.6. The issue is fixed in FlightPHP version 3.18.