CVE-2026-42564: fccview jotty · Path Traversal
Affects fccview jottySource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 8.2 High : upgrade to 1.22.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.22.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: evidence found.
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jotty and fccview/jotty to 1.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| fccviewjotty | Affected
| Fixed in
|
GitHubfccview/jottypkg:github/fccview/jottyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade jotty to version 1.22.0 or later, where this path traversal vulnerability is fixed. Since the vendor advisory confirms the fix in 1.22.0, applying this official update is the recommended remediation. No additional temporary mitigations are indicated.
Description
CVE-2026-42564 is a high-severity path traversal vulnerability in jotty, a self-hosted checklist and notes app by fccview. Versions prior to 1.22.0 allow unauthenticated attackers to read arbitrary files outside the intended directory via the /api/app-icons/[filename] endpoint. This occurs because the filename parameter is concatenated into a filesystem path without proper validation to prevent traversal. The vulnerability is fixed in version 1.22.0. No known exploits are reported in the wild.