Skip to main content
VulnerabilityPublished Updated

CVE-2026-42587: netty · Uncontrolled Resource Consumption

Affects nettySource GCVE Database

0

Not known to be exploited · CVSS 7.5 High : upgrade to 4.2.13.Final or 4.1.133.Final soon.

Data as of 26 Oct 2026, 18:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.2.13.Final, 4.1.133.Final
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade netty to 4.2.13.Final or 4.1.133.Final.

Affected software

ProductAffectedFixed in
netty nettyAffected
  • >=4.2.0.Alpha1 <4.2.13.Final
  • <4.1.133.Final
Fixed in
  • 4.2.13.Final
  • 4.1.133.Final

AI-suggested

This vulnerability is fixed in Netty versions 4.2.13.Final and 4.1.133.Final. Users should upgrade to these or later versions to remediate the issue. According to the Red Hat advisory, no effective mitigation other than upgrading is currently available or meets their criteria for ease of use and applicability. Therefore, patching is the recommended and necessary action.

Description

Netty versions prior to 4.2.13.Final and 4.1.133.Final contain a vulnerability in HTTP content decompression where the maxAllocation limit is ignored for Brotli (br), Zstandard (zstd), and Snappy content encodings. This allows an attacker to send specially crafted compressed payloads that cause unbounded memory allocation, leading to an out-of-memory denial of service. The issue affects both HTTP/1.x and HTTP/2 decompression components. The vulnerability is fixed in versions 4.2.13.Final and 4.1.133.Final.

References

Community reviews

Loading reviews…