CVE-2026-42607: getgrav grav · Code Injection
Affects getgrav gravSource CVE Database V5
Public exploit available (Exploit-DB) · CVSS 9.1 Critical : upgrade to 2.0.0-beta.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 4.3% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-beta.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 12 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 38 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
Grav CMS 2.0.0-beta.2 - Remote Code Execution
, 15 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade getgrav grav to 2.0.0-beta.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getgravgrav | Affected
| Fixed in
|
GitHubgetgrav/gravpkg:github/getgrav/gravOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Grav to version 2.0.0-beta.2 or later, where this vulnerability is fixed. Since no other remediation level or patch links are provided, applying this official fix is the recommended action.
Description
CVE-2026-42607 is a critical code injection vulnerability in the Grav file-based web platform. It affects versions prior to 2.0.0-beta.2. An authenticated administrator can exploit this flaw by uploading a crafted ZIP file through the Direct Install tool, bypassing protections against direct PHP uploads. This allows execution of arbitrary PHP code or installation of a persistent web shell, leading to remote code execution. The vulnerability is fixed in version 2.0.0-beta.2.