Skip to main content
VulnerabilityPublished Updated

CVE-2026-42609: getgrav grav · Improper Privilege Management

Affects getgrav gravSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 2.0.0-beta.2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0-beta.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade getgrav grav to 2.0.0-beta.2.

Affected software

ProductAffectedFixed in
getgravgravAffected
  • <2.0.0-beta.2
Fixed in
  • 2.0.0-beta.2
GitHubgetgrav/gravpkg:github/getgrav/gravOther threatsAffected
  • =2.0.0-beta.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Grav to version 2.0.0-beta.2 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated beyond the fixed version; therefore, users should verify with the vendor advisory for the latest remediation guidance.

Description

Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a business logic vulnerability in the Grav Admin Panel allows a low-privileged user (with only user creation permissions) to overwrite existing accounts, including the primary administrator. By creating a new user with a username that already exists, the system updates the existing account's metadata and permissions instead of rejecting the request. This leads to a Denial of Service (DoS) on administrative functions and Privilege De-escalation of the root account. This vulnerability is fixed in 2.0.0-beta.2.

References

Community reviews

Loading reviews…