CVE-2026-42611: getgrav grav · Cross-site Scripting
Affects getgrav gravSource CVE Database V5
Not known to be exploited · CVSS 8.9 High : upgrade to 2.0.0-beta.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-beta.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade getgrav grav to 2.0.0-beta.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getgravgrav | Affected
| Fixed in
|
GitHubgetgrav/gravpkg:github/getgrav/gravOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Grav to version 2.0.0-beta.2 or later to remediate this vulnerability. Since the vendor advisory confirms the fix is included starting from 2.0.0-beta.2, applying this update is the recommended and effective mitigation. Patch status is not explicitly stated beyond this version fix, so verify with the vendor for any additional guidance.
Description
Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a low-privileged (with the ability to create a page) user can cause XSS with the injection of svg element. The XSS can further be escalated to dump the entire system information available under /admin/config/info whenever a Super Admin visits the page; which can further be chained with the use of admin-nonce to do a complete server compromise (RCE). This vulnerability is fixed in 2.0.0-beta.2.