Skip to main content
VulnerabilityPublished

CVE-2026-42747: Easy Form Builder (WordPress plugin) · SQL Injection

Affects Easy Form Builder (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.0.7 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Easy Form Builder (WordPress plugin) to 4.0.7.

Affected software

ProductAffectedFixed in
hassantafreshiEasy Form BuilderAffected
  • <4.0.7
Fixed in
  • 4.0.7

AI-suggested

If you cannot patch yet, users should consider implementing web application firewalls or other SQL injection mitigations to reduce risk.

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in hassantafreshi Easy Form Builder easy-form-builder allows Blind SQL Injection.This issue affects Easy Form Builder: from n/a through <= 4.0.6.

References

Community reviews

Loading reviews…