Skip to main content
VulnerabilityPublished Updated

CVE-2026-42850: kovidgoyal kitty · Command Injection

Affects kovidgoyal kittySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 0.47.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.47.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade kitty and kovidgoyal/kitty to 0.47.0.

Affected software

ProductAffectedFixed in
kovidgoyalkittyAffected
  • <0.47.0
Fixed in
  • 0.47.0
GitHubkovidgoyal/kittypkg:github/kovidgoyal/kittyOther threatsAffected
  • <0.47.0
Fixed in
  • 0.47.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade kitty to version 0.47.0 or later, where this command injection vulnerability is fixed. There is no indication that the vulnerability is mitigated otherwise or that no action is required.

Description

Kitty is a cross-platform GPU based terminal. In versions prior to 0.47.0, it is possible to inject commands within the subshell through kitty error. A special escape code will make kitty return an error, this error is not escaped and will be correctly echoed back to the terminal with CRLF, as such it will be run by the shell in use. To exploit this bug, the victim must use a netcat or a similar program to connect to the attacker, or else listening for someone to connect. Once this condition is set, an attacker could pwn the computer of the victim using a special kitty's escape code that will run a command in the shell in use. Version 04.7.0 fixes the issue.

References

Community reviews

Loading reviews…