Skip to main content
VulnerabilityPublished

CVE-2026-42859: any1 neatvnc · Classic Buffer Overflow

Affects any1 neatvncSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 0.9.6 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade neatvnc and any1/neatvnc to 0.9.6.

Affected software

ProductAffectedFixed in
any1neatvncAffected
  • <0.9.6
Fixed in
  • 0.9.6
GitHubany1/neatvncpkg:github/any1/neatvncOther threatsAffected
  • <0.9.6
Fixed in
  • 0.9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade neatvnc to version 0.9.6 or later, where this buffer overflow vulnerability is fixed. Patch status is confirmed by the version fix information. No other mitigations are indicated.

Description

Neat VNC is a VNC server library. Prior to 0.9.6, a pre-authentication stack buffer overflow exists in neatvnc in the RSA-AES security type handler. An unauthenticated remote attacker who can reach the VNC listening socket can send a crafted security type 5 (RSA-AES) or security type 129 (RSA-AES-256) handshake with an oversized client RSA public key, causing rsa_aes_send_challenge in src/auth/rsa-aes.c to overflow a 1024-byte on-stack buffer when encrypting the server challenge. This results in at least a denial of service via server crash. This vulnerability is fixed in 0.9.6.

References

Community reviews

Loading reviews…