Skip to main content
VulnerabilityPublished Updated

CVE-2026-42945: F5 NGINX Plus · Heap-based Buffer Overflow.

Affects F5 NGINX PlusSource CVE Database V5

0
Compare

Not known to be exploited · 68% EPSS · CVSS 8.1 High : upgrade to 1.30.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
68.0% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX Open Source to 1.30.1.

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • =R36
  • =R32
Fixed in–
F5NGINX Open SourceAffected
  • >=0.6.27 <1.30.1
Fixed in
  • 1.30.1

AI-suggested

Red Hat has released security updates for affected NGINX packages, including version 1.26.3-1.el10_0.9 and related modules. Users should apply these official patches promptly to remediate the vulnerability. Exploitation requires specific non-default rewrite configurations; reviewing and adjusting these configurations may reduce risk. No additional mitigations are specified by the vendor advisory.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?). An unauthenticated attacker along with conditions beyond its control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…