CVE-2026-43018: Linux kernel · Bluetooth: hci_event: fix potential UAF in hci_le_remote_conn_param_req_evt
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 7.0.0-1006.6 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and should be applied promptly. Ubuntu has released updates addressing this vulnerability in linux-hwe-edge kernel versions 6.8.0-1064.72~22.04.1 and later. Users should upgrade to these fixed versions or later to mitigate the risk. No additional mitigation steps are indicated by the vendor advisory.
Description
A use-after-free (UAF) vulnerability was identified and fixed in the Linux kernel's Bluetooth subsystem, specifically in the handling of hci_le_remote_conn_param_req_evt events. The issue involved improper locking around connection lookup and field access, which could lead to concurrent freeing of resources. This vulnerability affects multiple versions of the linux-hwe-edge kernel prior to specific 6.8.x builds. A patch is available and has been released by Ubuntu as part of their security updates.
References
- ubuntu.com/security/CVE-2026-43018 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-43018 (opens in a new tab)
- git.kernel.org/linus/b255531b27da336571411248c2a72a350662bd09 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8608-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8609-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8619-1 (opens in a new tab)