CVE-2026-43041: Linux kernel · net: qrtr: replace qrtr_tx_flow radix_tree with xarray to fix memory leak
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 7.0.0-1006.6 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Linux kernel versions as provided by the vendor. The vendor advisory from Ubuntu (USN-8567-1) confirms that this and other kernel vulnerabilities have been fixed. Systems running affected versions should upgrade to patched kernel releases to remediate the issue.
Description
A memory leak vulnerability in the Linux kernel's net: qrtr subsystem was resolved by replacing the deprecated radix_tree data structure with xarray, which properly handles cleanup of internal nodes. The issue involved orphaned internal nodes remaining in the radix_tree after allocation failures, leading to unreclaimed memory. This vulnerability affects various Linux kernel versions prior to 5.15.0-186.196 and specific listed versions. The vulnerability has a medium severity with a CVSS score of 5.5 and does not impact confidentiality or integrity but affects availability due to the memory leak. A patch is available and should be applied to affected systems.
References
- ubuntu.com/security/CVE-2026-43041 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-43041 (opens in a new tab)
- git.kernel.org/linus/2428083101f6883f979cceffa76cd8440751ffe6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8597-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8608-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8609-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8610-1 (opens in a new tab)