Skip to main content
VulnerabilityPublished Updated

CVE-2026-43071: Linux kernel · Out-of-bounds Read

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-43071· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.4.0-1158.164 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.0-1158.164, 4.15.0-1206.221~14.04.1, 4.4.0-287.321~14.04.1 +130
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-27.27
Fixed in
  • 7.0.0-27.27
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available that limits the minimal number of dentry_hashtable buckets to two, preventing the out-of-bounds read. Users should apply the official Linux kernel updates that include this patch. The Ubuntu advisory USN-8488-1 references this and other kernel fixes; applying these updates will remediate the vulnerability.

Description

A critical out-of-bounds read vulnerability in the Linux kernel's dcache subsystem was resolved by limiting the minimal number of dentry_hashtable buckets to two. The flaw occurs when the user sets 'dhash_entries=1', causing an invalid memory access due to improper calculation of the hash shift and resulting in a kernel crash. This vulnerability is identified as CVE-2026-43071 and affects specific Linux kernel versions. The issue has been fixed by ensuring at least two buckets are allocated, preventing the out-of-bounds read.

References

Community reviews

Loading reviews…