CVE-2026-43081: Linux kernel · net: ipa: fix GENERIC_CMD register field masks for IPA v5.0+
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 7.0.0-1006.6 when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and included in Linux kernel updates for affected versions. System administrators should apply the updates promptly and reboot the system to ensure the fixes take effect. Due to an ABI change in the kernel update, recompilation and reinstallation of all third-party kernel modules are required. Follow the vendor advisory instructions for updating the system and rebuilding kernel modules as needed.
Description
In the Linux kernel, the following vulnerability has been resolved: net: ipa: fix GENERIC_CMD register field masks for IPA v5.0+ Fix the field masks to match the hardware layout documented in downstream GSI (GSI_V3_0_EE_n_GSI_EE_GENERIC_CMD_*). Notably this fixes a WARN I was seeing when I tried to send "stop" to the MPSS remoteproc while IPA was up.
References
- ubuntu.com/security/CVE-2026-43081 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-43081 (opens in a new tab)
- git.kernel.org/linus/9709b56d908acc120fe8b4ae250b3c9d749ea832 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8608-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8609-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8619-1 (opens in a new tab)