CVE-2026-43093: Linux kernel · Out-of-bounds Write
Affects Linux kernelSource CVE Database V5
Not known to be exploited · CVSS 7.8 High · fixed in a03975beb9f6af0d8ac051e30b2abeabe618414f : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-16.
- Patch
- Available – fixed in a03975beb9f6af0d8ac051e30b2abeabe618414f, a315e022a72d95ef5f1d4e58e903cb492b0ad931, 8769708add9eadeea8041a9761771bb715a87104 +8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in– |
AI-suggested
This vulnerability has been fixed in Linux kernel versions 4.20, 5.5, 5.7, and later. Users should upgrade to these or newer kernel versions to remediate the issue. Since this is a kernel-level vulnerability, applying the official kernel patches or upgrading to a fixed kernel release is the recommended mitigation.
Description
CVE-2026-43093 is a high-severity vulnerability in the Linux kernel's xsk (XDP socket) subsystem. It involves insufficient validation of UMEM headroom, which could lead to corrupted skb_shared_info when multi-buffering is used. The flaw is due to not properly accounting for tailroom and minimum Ethernet frame size, potentially causing memory corruption. This issue affects multiple Linux kernel versions prior to their respective fixed releases.
References
- git.kernel.org/stable/c/5f123bc278bf4e3283d8606321bebbfd299f4384 (opens in a new tab)
- git.kernel.org/stable/c/1a6051cd7e3e4c54ff3854a43b638b9292af5e67 (opens in a new tab)
- git.kernel.org/stable/c/8769708add9eadeea8041a9761771bb715a87104 (opens in a new tab)
- git.kernel.org/stable/c/a03975beb9f6af0d8ac051e30b2abeabe618414f (opens in a new tab)
- git.kernel.org/stable/c/0ec4d3f6e6934deb843b561ae048cd17218e5ad1 (opens in a new tab)
- git.kernel.org/stable/c/9ea6ba4f3195dcba6e8b3e7b2e748593b7cafb12 (opens in a new tab)
- git.kernel.org/stable/c/6523bc1b40e69301f24c14338b762af4739d6d39 (opens in a new tab)
- git.kernel.org/stable/c/a315e022a72d95ef5f1d4e58e903cb492b0ad931 (opens in a new tab)
- cert-portal.siemens.com/productcert/html/ssa-784472.html (opens in a new tab)