CVE-2026-43101: Linux kernel · ipv6: ioam: fix potential NULL dereferences in __ioam6_fill_trace_data()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 6.8.0-1035.38 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1035.38, 7.0.0-1006.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.0-1035.38 (linux-nvidia-tegra package) or 7.0.0-1006.6 (linux-nvidia package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available that addresses the vulnerability by adding proper NULL checks, replacing unsafe function calls, and ensuring correct memory access ordering. Users should update to Linux kernel version 7.0.0-1006.6 or later, or apply the corresponding patches for their specific kernel versions as provided by their distribution vendors.
Description
A high-severity vulnerability in the Linux kernel's IPv6 ioam subsystem was fixed by addressing potential NULL pointer dereferences in the __ioam6_fill_trace_data() function. The issue could cause system crashes, impacting availability but not confidentiality or integrity. The vulnerability affects Linux kernel versions prior to 7.0.0-1006.6 and several specific earlier versions. The fix includes improved NULL checks, replacing skb_dst_dev() with skb_dst_dev_rcu(), and adding missing READ_ONCE() calls.