Skip to main content
VulnerabilityPublished Updated

CVE-2026-43406: Linux kernel · libceph: prevent potential out-of-bounds reads in process_message_header()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-43406· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 5.15.0-1111.118~20.04.1 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1111.118~20.04.1, 5.15.0-1116.125~20.04.1, 5.15.0-1111.121~20.04.1 +69
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threatsAffected
  • <6.17.0-40.40
Fixed in
  • 6.17.0-40.40
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1019.19
Fixed in
  • 6.17.0-1019.19
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1020.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1020.22
Fixed in
  • 6.17.0-1020.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied. The Ubuntu security advisory USN-8490-1 confirms that this and other Linux kernel vulnerabilities have been fixed in updated kernel packages. After applying the update, a system reboot is required. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Users should update to the fixed kernel versions as per their distribution's guidance.

Description

A high-severity vulnerability (CVE-2026-43406) in the Linux kernel's libceph component could allow out-of-bounds reads in the process_message_header() function if a message frame is maliciously corrupted. This issue is due to insufficient bounds checking before decoding the message header. The vulnerability affects specific Linux kernel versions and has been addressed by an official patch.

References

Community reviews

Loading reviews…