Skip to main content
VulnerabilityPublished Updated

CVE-2026-43407: Linux kernel · libceph: Fix potential out-of-bounds access in ceph_handle_auth_reply()

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-43407· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 3.13.0-214.265 : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.13.0-214.265, 4.4.0-1156.162, 4.15.0-1205.220~14.04.1 +122
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-40.40
Fixed in
  • 6.17.0-40.40
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1019.19
Fixed in
  • 6.17.0-1019.19
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • 6.14.0-1004.4 – 6.17.0-1020.20
16 affected builds
Fixed in–
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1020.22
Fixed in
  • 6.17.0-1020.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released as part of Linux kernel updates. Users should update their Linux kernel to the fixed versions provided by their distribution vendors, such as the Ubuntu security notice USN-8490-1. After updating, a system reboot is required to apply the kernel changes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigations are required beyond applying the official patch.

Description

A vulnerability in the Linux kernel's libceph component involving an out-of-bounds memory access in the ceph_handle_auth_reply() function has been fixed. The issue arises from an integer overflow caused by the payload_len field being stored as a signed int, allowing a crafted message to trigger unsafe memory access. The fix changes payload_len and result_msg_len to unsigned 32-bit integers and adds sanity checks to prevent lengths exceeding the segment size. This vulnerability has a high severity with a CVSS score of 9.1 and affects multiple Linux kernel versions. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…