CVE-2026-43414: Linux kernel · scsi: qla2xxx: Completely fix fcport double free
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 4.4.0-1156.162 : patch Linux kernel as a priority.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.0-1156.162, 4.15.0-1205.220~14.04.1, 4.4.0-283.317~14.04.1 +121
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available and included in Linux kernel updates version 6.17.0-1019.19 and later for linux-aws. Users should apply the latest kernel updates from their vendor and reboot the system to ensure the vulnerability is remediated. Due to an ABI change, third-party kernel modules may need recompilation and reinstallation after updating. No additional mitigation steps are required beyond applying the official patches.
Description
A critical vulnerability (CVE-2026-43414) in the Linux kernel's SCSI subsystem (qla2xxx driver) involving a double free of fcport objects has been resolved. This flaw occurs in the qla24xx_els_dcmd_iocb() function where fcport is freed twice, potentially leading to system compromise. The issue affects many versions of the linux-aws kernel prior to the fixed releases. A high-severity CVSS 3.1 score of 9.8 is assigned. Official patches are available and included in Linux kernel updates version 6.17.0-1019.19 and later. Users should update and reboot to apply the fixes. The vulnerability is not known to be exploited in the wild.
References
- ubuntu.com/security/CVE-2026-43414 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-43414 (opens in a new tab)
- git.kernel.org/linus/c0b7da13a04bd70ef6070bfb9ea85f582294560a (opens in a new tab)
- git.kernel.org/stable/c/c0b7da13a04bd70ef6070bfb9ea85f582294560a (opens in a new tab)
- git.kernel.org/stable/c/d48ea85463f5b34f7b92ea0a13eddf1ab993da7b (opens in a new tab)
- ubuntu.com/security/notices/USN-8490-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8491-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8492-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8493-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8492-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8497-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8498-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8499-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8493-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8508-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8492-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8490-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8492-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8492-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8527-1 (opens in a new tab)