Skip to main content
VulnerabilityPublished Updated

CVE-2026-43515: Apache Tomcat · Improper Authorization

Affects Apache TomcatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 8.5.101 or 7.0.110 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.101, 7.0.110
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat/tomcat to 8.5.101 or 7.0.110.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache TomcatAffected
  • >=11.0.0-M1 <=11.0.21
  • >=10.1.0-M1 <=10.1.54
  • >=9.0.0.M1 <=9.0.117
  • >=8.5.0 <=8.5.100
  • >=7.0.0 <=7.0.109
Fixed in–
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • =8.5.0 <8.5.101
  • =7.0.0 <7.0.110
Fixed in
  • 8.5.101
  • 7.0.110

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat installations to versions 11.0.22, 10.1.55, or 9.0.118 as these versions contain the official fix for this vulnerability. No other mitigation or temporary workaround is indicated in the available data. Patch status is confirmed by the vendor advisory recommending these versions.

Description

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

References

Community reviews

Loading reviews…