CVE-2026-43869: Apache Thrift · Improper Validation of Certificate with Host Mismatch
Affects Apache ThriftSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 0.23.0 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.23.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Apache Thrift and org.apache.thrift/libthrift to 0.23.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Thrift | Affected
| Fixed in
|
Mavenorg.apache.thrift/libthriftpkg:maven/org.apache.thrift/libthriftOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in Apache Thrift version 0.23.0. Users are strongly recommended to upgrade to this version or later to remediate the vulnerability. Red Hat has released security updates including this fix for affected products such as Cryostat 4 on RHEL 9. No alternative mitigations meeting Red Hat's criteria are currently available. Users should apply the vendor-provided updates as soon as possible.
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
References
- lists.apache.org/thread/3hsgl1b69wzq3ry39scqbv2dhyl3j52r (opens in a new tab)
- openwall.com/lists/oss-security/2026/05/05/3 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-43869 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2466660 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-43869.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:28010 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22423 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22347 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:23345 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:24503 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30651 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36882 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:24539 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:25273 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:26586 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42644 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:27126 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21769 (opens in a new tab)