CVE-2026-43911: dani-garcia vaultwarden · Insufficient Session Expiration
Affects dani-garcia vaultwardenSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.35.5 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.35.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vaultwarden and dani-garcia/vaultwarden to 1.35.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dani-garciavaultwarden | Affected
| Fixed in
|
GitHubdani-garcia/vaultwardenpkg:github/dani-garcia/vaultwardenOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Vaultwarden to version 1.35.5 or later, where this vulnerability is fixed by properly invalidating refresh tokens upon security_stamp rotation. Since this is an on-premises product, administrators should apply the update promptly to mitigate the risk. Patch status is confirmed fixed in version 1.35.5.
Description
Vaultwarden versions prior to 1.35.5 contain a vulnerability where refresh tokens are not invalidated after certain security-sensitive user actions, such as password changes or key rotations. This allows an attacker with a previously obtained refresh token to maintain session access despite the user attempting to secure their account. The issue is identified as insufficient session expiration (CWE-613) and has a CVSS score of 6.8 (medium severity). The vulnerability is fixed in version 1.35.5.