Skip to main content
VulnerabilityPublished

CVE-2026-43912: dani-garcia vaultwarden · Improper Authorization

Affects dani-garcia vaultwardenSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.35.5 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.35.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vaultwarden and dani-garcia/vaultwarden to 1.35.5.

Affected software

ProductAffectedFixed in
dani-garciavaultwardenAffected
  • <1.35.5
Fixed in
  • 1.35.5
GitHubdani-garcia/vaultwardenpkg:github/dani-garcia/vaultwardenOther threatsAffected
  • <1.35.5
Fixed in
  • 1.35.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Vaultwarden version 1.35.5. Users should upgrade to version 1.35.5 or later to remediate this issue. No other official remediation or temporary fixes are documented. Since this is not a cloud service, patching the affected software is required to mitigate the risk.

Description

Vaultwarden versions prior to 1.35.5 contain an improper authorization vulnerability that allows an attacker with admin privileges in one organization and low privileges in another to escalate access across organizations. The flaw arises because group-management endpoints do not verify that membership and collection IDs belong to the same organization, enabling unauthorized access and modification of vault data from another organization. This vulnerability is fixed in version 1.35.5.

References

Community reviews

Loading reviews…