CVE-2026-43914: dani-garcia vaultwarden · Improper Restriction of Excessive Authentication Attempts
Affects dani-garcia vaultwardenSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 1.35.4 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.35.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade vaultwarden and dani-garcia/vaultwarden to 1.35.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dani-garciavaultwarden | Affected
| Fixed in
|
GitHubdani-garcia/vaultwardenpkg:github/dani-garcia/vaultwardenOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Vaultwarden to version 1.35.4 or later, where this vulnerability is fixed. Until upgraded, be aware that brute-force protections can be bypassed via the email 2FA endpoint.
Description
Vaultwarden versions prior to 1.35.4 contain a vulnerability that allows attackers to bypass brute-force login protections when email two-factor authentication (2FA) is enabled. The vulnerability arises because the 2FA email function send_email_login acts as an oracle to verify username-password correctness without rate limiting. This flaw enables brute-force password attempts even against accounts without email 2FA configured. The issue is fixed in version 1.35.4. The CVSS score is 7.3, indicating a high severity vulnerability.