Skip to main content
VulnerabilityPublished Updated

CVE-2026-43916: identd-ng pam_authnft · Out-of-bounds Read

Affects identd-ng pam_authnftSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 0.2.0-alpha soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.2.0-alpha
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade identd-ng pam_authnft to 0.2.0-alpha.

Affected software

ProductAffectedFixed in
identd-ngpam_authnftAffected
  • <0.2.0-alpha
Fixed in
  • 0.2.0-alpha
GitHubidentd-ng/pam_authnftpkg:github/identd-ng/pam_authnftOther threatsAffected
  • =0.2.0-alpha
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in identd-ng version 0.2.0-alpha. Users should upgrade to this version or later to remediate the vulnerability. Since the vendor advisory does not provide additional remediation details, applying the official update is the recommended action. Patch status beyond this is not explicitly confirmed, so users should verify with the vendor for the latest guidance.

Description

CVE-2026-43916 is a high-severity vulnerability in the pam_authnft module of identd-ng versions prior to 0.2.0-alpha. It involves a heap buffer over-read caused by improper handling of crafted NETLINK_SOCK_DIAG replies in the peer_lookup_tcp function. This flaw allows reading beyond allocated memory boundaries, potentially leading to information disclosure or application instability. The vulnerability has been fixed in version 0.2.0-alpha. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…