CVE-2026-43930: parse-server · Race Condition
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 9.9.0-alpha.2 or 8.6.76 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.9.0-alpha.2, 8.6.76
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.9.0-alpha.2 or 8.6.76; parse-community/parse-server to 8.6.76.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade parse-server to version 8.6.76 or later, or 9.9.0-alpha.2 or later, where this race condition is fixed. No other mitigation is indicated. Patch status is confirmed by the vendor's versioning information.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.76 and 9.9.0, a race condition in the MFA SMS one-time password (OTP) login path allows two concurrent /login requests carrying the same OTP to both succeed and both receive valid session tokens, breaking the single-use property of the OTP. The vulnerability requires the attacker to already possess the victim's password and intercept the active SMS OTP (e.g. via SIM swap, network mirror, or phishing relay) and to race the legitimate login request, so the practical attack surface is narrow. This vulnerability is fixed in 8.6.76 and 9.9.0.