CVE-2026-43972: ninenines gun · Origin Validation Error
Affects ninenines gunSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.4.0 when convenient.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.0, 567863ff53802fed21c3b3f25812db7f7ae29676
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gun to 2.4.0; gun to 567863ff53802fed21c3b3f25812db7f7ae29676.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nineninesgun | Affected
| Fixed in
|
| nineninesgun | Affected
| Fixed in
|
Hexgunpkg:hex/gunOther threats | Affected
| Fixed in
|
GitHubgunpkg:github/gunOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:ninenines:gun:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid using vulnerable versions of gun with untrusted HTTP/2 servers or disable HTTP/2 PUSH_PROMISE handling if possible.
Description
CVE-2026-43972 is an origin validation error vulnerability in the ninenines gun HTTP/2 module (gun_http2). It allows a malicious or compromised HTTP/2 server to inject cookies scoped to arbitrary third-party domains into the client's cookie store via unvalidated PUSH_PROMISE authority headers. This violates HTTP/2 protocol requirements and can enable session fixation and potential account takeover without user interaction. The issue affects gun versions from 2.0.0 up to but not including 2.4.0.