CVE-2026-43998: patriksimek vm2 · Link Following
Affects patriksimek vm2Source CVE Database V5
Not known to be exploited · CVSS 8.5 High · fixed in 3.11.0 : patch patriksimek vm2 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patriksimekvm2 | Affected
| Fixed in– |
npmvm2pkg:npm/vm2Other threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in vm2 version 3.11.0. Users should upgrade from version 3.10.5 to 3.11.0 or later to remediate this vulnerability. No alternative mitigations are specified in the vendor advisory. Patch status is confirmed by Red Hat and the official vm2 advisory.
Description
vm2 is an open source vm/sandbox for Node.js. In 3.10.5, NodeVM's require.root path restriction can be bypassed using filesystem symlinks, allowing sandboxed code to load modules from outside the allowed root directory in host context. Because path validation uses path.resolve() (which does not dereference symlinks) but module loading uses Node's native require() (which does), an attacker can load arbitrary host-realm modules and achieve remote code execution. This vulnerability is fixed in 3.11.0.
References
- github.com/patriksimek/vm2/security/advisories/GHSA-cp6g-6699-wx9c (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-43998 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477206 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-43998.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:50850 (opens in a new tab)